Что такое WinToFlash

WinToFlash – это приложение, позволяющее полностью перенести программу установки Windows XP, Windows 2003, Windows Vista, Windows 2008, Windows 7, Windows 8 на USB накопитель за несколько кликов мышки. Это означает, что вы можете установить Windows с флэш-карты, HDD или другого накопителя на ваш компьютер или нэтбук.

WinToFlash может перенести ваш Live CD/DVD на USB накопитель, например, BartPE. После использования накопителя вы сможете полностью очистить накопитель и отформатировать его для ежедневного использования.

Примечание Полный список возможностей смотрите в разделе Функциональные возможности.
© Novicorp 2009-2012
 разработка руководства андрей павлов


Функциональные возможности

WinToFlash обеспечивает следующие функциональные возможности:

  • Перенос программы установки Windows XP/2003/Vista/2008/7/8 на USB накопитель.
  • Полная поддержка редакций Windows 32-разрядных (x86) и 64-разрядных (x64).
  • Перенос дисков восстановления или мини-ОС (BartPE на Windows XP/2003, WinPE на Vista/2008/7/8) на USB накопитель.
  • Очистка USB накопителя (полное удаление всей информации).
  • Создание USB накопителя с аварийным загрузчиком Windows 2000/XP/2003.
  • Перенос MS-DOS на USB накопитель.
  • Создание USB накопителя с Windows XP/2003 Recovery Console.
  • Форматирование USB накопителя в FAT16 или FAT32.
  • Детальная настройка любых опций FAT для лучшей совместимости.
  • Детальная настройка любых опций таблицы разделов.
  • Выбор загрузчика USB накопителя, например GRUB или Standard.
  • Выбор типа раздела – CHS или LBA для лучшей совместимости с некоторыми материнскими платами.
  • Создание файла ответов для Windows Setup. Добавьте серийный номер, имя пользователя и т.д.
  • Детальная настройка процесса переноса Windows Setup.
  • Проверка накопителя USB на предмет наличия ошибок файловой системы после переноса Windows Setup.
  • Исправление некоторых проблем Windows Setup, например 0x6B BSOD.
  • WinToFlash – portable приложение, вы можете взять его с собой на съёмном диске и запустить на любом компьютере.
  • Поддержка профилей переноса – сохраните и загрузите параметры переноса в любое время.
  • Поддержка шифрования ключа Windows в профиле.
  • Детальный лог-файл.
  • Напоминание об обновлениях.
  • Простой, классический интерфейс, как утилита ntbackup.
  • Мастер, который запрашивает всего два параметрами для быстрого переноса Windows Setup.
  • Поддержка многоязычности.
  • Поддержка АнтиСМС для удаления блокировщиков компьютера (отправь СМС на номер, пополнил счет для разблокировки и других).
  • Теперь содержит WinToFlash Suggestor.
Примечание Состав доступных функций программы изменяется в зависимости от используемого вами типа лицензии.

Возможности АнтиСМС (АнтиВинлокер):

  • Программа работает с любым количеством винчестеров, систем и пользователей, x86 и x64 от WinXP и выше.
  • Удаляются файлы autorun.inf в корне каждого логического диска, если они существуют.
  • В профилях пользователей удаляются исполняемые файлы из тех папок, где их быть не должно.
  • Полностью очищаются системные и пользовательские временные папки.
  • Все нестандартные записи в файле hosts будут закомментированы.
  • Автозапуск на всех устройствах кроме дисковода будет отключен.
  • Критически важные места реестра (вроде Shell и Userinit) будут восстановлены.
  • Все временные ключи автозапуска (вроде RunOnce и RunOnceEx) будут очищены.
  • Все отладчики системных процессов в Image File Execution Options будут удалены.
  • Все ограничения (Policies) пользователей и системы будут удалены.
  • В политике ограниченного использования программ будет выставлен неограниченный уровень.
  • Все неподписанные службы будут отключены, можно восстановить через msconfig после загрузки системы.
  • Все неподписанные файлы из автозагрузки реестра будут отключены, можно восстановить через msconfig.
  • Отключаются неподписанные файлы в папках автозагрузки, можно восстановить через msconfig.
  • Неподписанные назначенные задания переименовываются в *.bak, чтобы можно было восстановить.
  • Возможно восстановление параметров сети из рабочей системы после их нарушения троянами.
  • Восстанавливаются параметры запуска исполняемых файлов.
  • Из автозагрузки реестра и папок автозапуска убираются скрипты, можно восстановить через msconfig.
  • В Windows 7 для msconfig также добавляется время отключения элементов автозагрузки и служб.
  • Для Windows XP x86 восстанавливаются настройки загрузки в безопасном режиме.
  • Для WinXP x86, Vista x86-x64 и Win7 x86-x64 восстанавливаются основные системные файлы, если они не подписаны.
  • Вылечиваются все известные MBR-блокировщики, резервная копия заражённого сектора сохраняется в папке Backup.
  • Реализовано сохранение нестандартного MBR, это позволит быстрее лечить неизвестные трояны.
  • Реализована более глубокая чистка системы от вредоносных действий троянов.
  • В папках автозапуска также обрабатываются ярлыки, неподписанные можно восстановить через msconfig.
  • Правильно распознаются все разделы, независимо от того, как перемешались их буквы в WinPE.
  • Загрузочный диск поддерживает exFAT и содержит новейшие драйвера контроллеров.
  • Правильно обрабатывается параметр AppInit_DLLs, из него убираются только неподписанные библиотеки.
  • Резервные копии файлов и логи работы программы сохраняются в папке %Temp%\AntiSMS.
  • Поддерживается база проверенных файлов программы Universal Virus Sniffer.


WinToFlash

содержание раздела

Аппаратные и программные требования

Дистрибутив программы

Запуск программы

Начало работы

Удаление программы


Аппаратные и программные требования

Для использования Novicorp WinToFlash ваш компьютер должен удовлетворять ряду требований.

Общие требования:

  • Процессор Intel Pentium 233 МГц 32-разрядный (x86) или выше (или совместимый аналог).
  • Не менее 64 МБ свободной оперативной памяти (RAM).
  • Не менее 20 МБ свободного места на жестком диске.
  • CD- / DVD-ROM (для использования дистрибутивных CD- / DVD –дисков Windows).
  • Подключение к интернету (для обновления программы, а также для обратной связи).
  • Клавиатура и Мышь Microsoft или другое указывающее устройство.
  • Видеокарта с видеопамятью объемом не менее 64 МБ и монитор Super VGA (800 x 600) или с большим разрешением.
  • OC Windows XP/2003/Vista/2008/7/8.
Примечание Настоящие требования к компьютеру могут изменяться, в зависимости от конфигурации компьютера и других факторов.

Для использования программы предъявляются следующие требования к накопителям:

  • USB-накопитель объемом не менее 1 ГБ для переноса ОС Windows 2003/XP.
  • USB-накопитель объёмом не менее 4 ГБ для переноса ОС Windows Vista/2008/7/8.


Дистрибутив программы

Дистрибутив WinToFlash является портативным, то есть не требует для работы установки программы. Программа распространяется в виде ZIP архива. Для начала работы программы необходимо извлечь папку с программой путём распаковки, используя проводник Windows или другую специальную программу.

Примечание Подробнее о том, как извлечь содержимое архива смотрите в документации операционной системы Windows или другой используемой вами программы для работы с архивами.

Чтобы скачать последнюю версию Wintoflash, а также любые другие опубликованные ранее версии, посетите официальный сайт программы – страницу Загрузка и выберите наиболее удобный для вас способ загрузки.

Вы можете загрузить дистрибутив программы WinToFlash одним из следующих способов:

  • По Torrent протоколу. Предусмотрена возможность загрузки как по .torrent-файлу так и по мagnet-ссылке.
  • По FTP протоколу. Для загрузки используются собственные ftp-узлы Novicorp.
  • Сайты партнеров, ряд из которых представлен на английском и других языках.


Запуск программы

После распаковки архива программа готова к работе. Для запуска программы используйте файл WinToFlash.exe в корневой папке WinToFlash.

Для запуска программы в среде Windows Vista, Windows 7 или Windows 8 во избежание конфликтов с компонентом UAC (контроль учётных записей) выполните следующие действия:

  1. Наведите курсор мыши на значок программы, нажмите правую клавишу мыши, в открывшемся контекстом меню выберите пункт «Запуск от имени администратора»;
  2. При появлении запроса UAC о внесении изменений разрешите запуск программы нажатием на кнопку «Да».

Окно заставки (splash screen)

После чего на экране должно появиться окно заставки (splash screen) WinToFlash, которое известит вас о запуске программы. Если окно заставки не появилось, попробуйте повторить запуск программы в соответствии с приведённой выше инструкцией. В случае, если повторный запуск программы также оказался безуспешным и не привёл к появлению окна заставки, обратитесь за помощью в решении этого вопроса в службу технической поддержки WinToFlash.


Начало работы

При первом запуске программа встретит вас приветственным окном Мастер первого запуска. Следуя инструкциям мастера, вам необходимо будет ознакомиться с особенностями использования программы и принять условия лицензионного соглашения.

Далее мастер предложит активировать программу, для этого необходимо нажать на кнопку Активировать лицензию и указать файл лицензии (если вы приобрели одну из доступных типов лицензий). Если вы хотите использовать бесплатную версию, нажмите на кнопку Далее > для перехода к следующему этапу.

При условии наличия на вашем компьютере активного Интернет-подключения, вам необходимо будет просмотреть рекламу от компаний-партнёров, после чего WinToFlash предложит вам установить дополнительное программное обеспечение.

На следующем этапе вы увидите сообщение о завершении работы мастера, нажав на кнопку Далее > (или Закрыть), вы сможете покинуть мастер первого запуска и начать работу с приложением.


Удаление программы

Для удаления WinToFlash воспользуйтесь стандартными средствами Windows, для этого предварительно выделите папку программы, выберите в контекстном меню пункт «Удалить» или нажмите клавишу Delete на клавиатуре. В диалоговом окне с запросом об удалении папки подтвердите удаление программы нажатием кнопки «Да».

После чего программа WinToFlash будет полностью удалена с вашего компьютера.

Примечание Обратите внимание, что при удалении папки программы автоматически будут безвозвратно удалены все текущие настройки программы, рабочие профили, файл лицензии, а также вся статистическая информация о работе программы. В случае, если вы намерены в дальнейшем использовать программу, рекомендуется предварительно сохранить необходимые данные, выполнив их резервное копирование.


Интерфейс

содержание раздела

Интерфейс программы

Элемент взаимодействия Мастер


Интерфейс программы

В главном окне программы сосредоточены элементы интерфейса, предоставляющие доступ ко всем основным функциям программы.

Главное окно программы можно условно разделить на две части (1,2) и выделить следующие элементы интерфейса (3-5):

– меню, посредствам которого осуществляется управление и настройка программы;

– рабочая область, где происходит первое знакомство, здесь вы можете определиться с выбором режима работы программы;

– выбор режима работы программы;

– открытие окна Настройки для выбора языка интерфейса программы;

– уведомление об обновлении.

Главное окно программы

Главное окно программы

Кнопки для просмотра содержимого окна

Окно Настройки и работа в расширенном режиме предусматривают наличие дополнительных кнопок для просмотра содержимого окна.

Нажатие на кнопку Влево или Вправо позволяет перемещаться влево или вправо соответственно для просмотра всех вкладок в верхней части окна.


Элемент взаимодействия Мастер

Работая с WinToFlash, вы неоднократно столкнётесь с использованием мастера – одним из ключевых элементов взаимодействий с программой (мастер первого запуска, мастер переноса, мастер обновления).

Мастер состоит из последовательности окон (шагов), переключение между которыми осуществляется с помощью кнопок < Назад и Далее >. Работа мастера завершается с появлением окна, извещающего о завершении работы мастера, после нажатия на кнопку Далее >. Для прекращения работы мастера на любом этапе следует нажать на кнопку Выход (или Закрыть).


Главное меню программы

Главное меню программы (далее также «меню программы», «меню») обеспечивает управление отдельными компонентами программы, обеспечивает быстрый доступ к часто используемым задачам и функциям, служит для доступа к другим составляющим, объединённым в меню программы.

Элементы управление, задачи и другие составляющие в меню, в верхней части окна, объединены в следующие разделы, которые представляют собой отдельные самостоятельные меню:

  • Задание;
  • Вид;
  • Сервис;
  • Справка.


Меню Задание

Раздел меню Задание обеспечивает выполнение типовых задач, таких как: создание нового задания и запуск процесса переноса, работа с профилями, а также завершение работы программы.

Меню Задание

В меню Задание представлены следующие элементы управления:

  • Новое – переход в расширенный режим работы для выбора типа задания;
  • Запустить – запуск процесса переноса в расширенном режиме работы;
  • Загрузить – загрузка сохранённого профиля;
  • Сохранить – сохранение профиля (в случае, если вы предварительно загрузили сохранённый ранее профиль, программа автоматически его перезапишет);
  • Сохранить как – сохранение профиля с возможность определить параметры сохранения, то есть назначить профилю другое имя;
  • Выход – закрытие и завершение работы программы.


Меню Вид

Раздел меню Вид содержит элемент управления Обновить, функция носит служебный характер, предназначена для переводчиков, позволяет обновить язык из DLL на экране.


Меню Сервис

Раздел меню Сервис позволяет переключаться в режим мастера, обеспечивает открытие журнала событий и окна настроек программы.

Меню Сервис

В меню Сервис представлены следующие элементы управления:

  • Переход в режим мастера – переключение программы в режим мастера;
  • Журнал событий – запуск журнала событий для просмотра информации о работе программы;
  • Настройки – открытие окна настройки параметров программы.


Меню Справка

Раздел меню Справка служит для обращения к справочному руководству, содержит ссылки на информационные ресурсы WinToFlash в Интернет, обеспечивает возможности обращения в службу технической поддержки и просмотр статистической информации, включает функции проверки обновления и активации программы, обеспечивает вызов окна О программе.

Меню Справка

В меню Справка представлены следующие элементы управления и составляющие:

  • Справка Novicorp WinToFlash – вызов справочной системы по WinToFlash.
  • Статистика – вызов окна статистика работы для просмотра основных сведений об использовании программы.
  • Novicorp в Интернет – открывает сайт Novicorp в Интернет.
  • Домашняя страница – открывает домашнюю страницу WinToFlash в Интернет.
  • Устранение неполадок – открывает сайт форума WinToFlash в Интернет.
  • Обсуждение – открывает сайт форума WinToFlash в Интернет, на странице обсуждения.
  • Обратная связь – открывает форму обратной связи для обращения в службу поддержки WinToFlash.
  • Проверить наличие обновлений – запуск мастера обновления.
  • Активировать продукт – активация программы.
  • О программе Novicorp WinToFlash – вызов окна, содержащего информацию о программе.


Подготовительный этап

WinToFlash поддерживает любые типы USB накопителей (USB-флеш-накопители и USB HDD) объёмом не менее 1 ГБ – для переноса Windows XP/2003, не менее 4 ГБ – для переноса Windows Vista/2008/7/8.

Процесс создание загрузочного накопителя предполагает перенос дистрибутива одним из следующих способов:

  • Использование физического CD- /DVD-ROM в качестве источника файлов Windows. Для этого необходимо перед началом работы с программой вставить необходимый диск в CD- /DVD-ROM.
  • Использование папки на вашем компьютере. Образы оптических дисков (ISO, BIN, MDS или любые другие), а также архивы (ZIP, RAR, LZW или любые другие) не поддерживаются программой. В этом случае вам необходимо предварительно извлечь файлы Windows из образов или архивов в указанную папку на жёстком диске вашего компьютера.
  • Использование виртуального CD- /DVD-ROM в качестве источника файлов Windows. Для этого необходимо перед началом работы с программой монтировать образ вашего диска на виртуальное устройство CD- /DVD-ROM.
Примечание Рекомендуется использование оригинальных CD/DVD от Microsoft, если это возможно, не все дистрибутивы могут быть перенесены на USB накопитель. Диски (а также их образы) могут быть повреждены или модифицированы неподдерживаемым способом.
Предупреждение В процессе переноса вся информация на накопителе будет удалена. Во избежание потери важной информации необходимо предварительно создать резервную копию ваших данных, скопировав с него информацию на жёсткий диск или в любое другое место.


Процесс переноса

Процесс переноса – это процедура создания и подготовки накопителя, в ходе которого происходит перенос дистрибутива Windows, WinPE или MS-DOS и др. на USB накопитель.

Процесс переноса WinToFlash осуществляется в одном из следующих режимов работы программы:

  • Режим мастера – режим работы программы, в котором все настройки переноса выполняются программой автоматически в фоновом режиме, то есть от вас не требуется принятия решения по осуществлению тех или иных настроек для предварительной подготовки накопителя.
  • Расширенный режим – режим работы программы, который отличается возможностью полностью настроить процесс переноса, автоматизировать и настроить процесс установки Windows, произвести детальную настройку форматирования, определить опции FAT и конфигурацию MBR, выбрать используемый загрузчик, настроить параметры проверки накопителя.


Режим мастера

Режим мастера – режим работы программы, в котором все настройки переноса выполняются программой автоматически в фоновом режиме, то есть от вас не требуется принятия решения по осуществлению тех или иных настроек для предварительной подготовки накопителя.

Режим мастера рекомендуется использовать для ознакомления с программой, а также, если процесс переноса не требует задания дополнительных параметров и детальной настройки.

Мастер состоит из последовательности окон (шагов), переключение между которыми осуществляется нажатием на кнопки < Назад и Далее >. Работа мастера завершается с появлением окна извещающего о завершении работы мастера, после нажатия на кнопку OK. Для прекращения работы мастера на любом этапе следует нажать на кнопку Выход (или Закрыть).

Запуск мастера

Запуск мастера осуществляется одним из следующих способов:

  • кнопка Запуск мастера (запуск мастера) в главном окне программы;
  • выбрав пункт Переход в режим мастера, в меню меню Сервис главного меню программы;
  • автоматически, запуск мастера осуществляется автоматически при запуске программы, при включённой опции Запускать в режиме мастера в настройках программы.

Окно Мастер

Шаг 1. Окно приветствия

На первом шаге вы можете вернуться обратно в главное окно программы, кликнув по ссылке расширенный режим, а также установить необязательный флажок Всегда запускать в режиме мастера, что обеспечит при следующем запуске WinToFlash автоматическое переключение в режим мастера. Нажатие на кнопку Выход (или Закрыть) также позволит вернуться обратно в главное окно программы.

Для перехода к следующему шагу подготовки накопителя необходимо нажать кнопку Далее >.

Шаг 2. Основные параметры

На втором шаге необходимо указать расположение файлов Windows и USB накопитель для подготовки Для указания путей вы можете воспользоваться кнопкой Выбрать напротив соответствующего элемента окна, после чего в открывшемся окне указать путь или ввести пути самостоятельно в полях ввода. Предусмотрена возможность указать в качестве накопителя как USB-флэш-накопитель, так и внешний жёсткий диск (USB HDD).

Предупреждение Обращаем ваше внимание, что в процессе создания загрузочного накопителя произойдёт удаление всех данных, хранящихся на накопителе. А в случае использования вами жёсткого диска наряду с удалением данных будут также удалены все разделы (если жёсткий диск был размечен на несколько разделов).

После того как вы указали путь к файлам Windows и накопитель, подтвердите выбор нажатием на кнопку Далее >.

Шаг 3. Лицензионное соглашение

На данном шаге вы можете ознакомиться с условиями лицензионного соглашения Microsoft. Для продолжения необходимо принять условия лицензионного соглашения, установив флажок Я принимаю условия лицензионного соглашения, и нажать кнопку Продолжить.

Условия лицензионного соглашения

Окно Лизензионное соглашение

Шаг 4. Подтверждение форматирования

На четвёртом шаге необходимо подтвердить форматирование накопителя, нажав на кнопку Продолжить, при необходимости предварительно заполнив поле Результат (в зависимости от настроек программы). Вы можете активировать дополнительное поле Результат в процессе работы мастера, установив флажок Включить CAPTCHA, после чего необходимо будет заполнить соответствующее поле для подтверждения форматирования.

Расширенный диалог Предупреждение о форматировании (Captcha)

Окно Предупреждение о форматировании

Шаг 5. Процесс подготовки накопителя

На данном шаге WinToFlash осуществляет подготовку вашего накопителя. Все действия выполняются программой автоматически и не требуют вашего участия. В процессе подготовки WinToFlash в окне с индикатором состояния выводит информацию о ходе выполнения переноса. Дождитесь завершения процесса переноса, когда индикатор состояния достигнет значения 100%, а ниже вы увидите статус Завершено, вы можете нажать кнопку Далее > для перехода в окно завершения работы мастера.

Предупреждение Во избежание повреждения диска и возможных неполадок, не извлекайте накопитель и не прерывайте начавшуюся процедуру подготовки накопителя.

Мастер (подготовка накопителя)

Окно Подготовка накопителя

Шаг 6. Завершение работы мастера

Для закрытия мастера нажмите на кнопку Выход (или Закрыть) или перейдите по ссылке, которая предлагает вернуться на главный экран.

Мастер (завершение работы)

Окно Завершение работы мастера


Расширенный режим

Расширенный режим – режим работы программы, в котором все предварительные действия по подготовке накопителя для переноса осуществляются вами самостоятельно.

Расширенный режим – отличается возможностью создать различные типы загрузочных накопителей, полностью настроить процесс переноса, автоматизировать и настроить процесс установки Windows, произвести детальную настройку форматирования, определить опции FAT и конфигурацию MBR, выбрать используемый загрузчик, настроить параметры проверки накопителя. В расширенном режиме работы доступны все поддерживаемые WinToFlash типы заданий.

Работа в расширенном режиме начинается с выбора типа задания, WinToFlash обеспечивает следующие типы заданий.

  1. Перенос программы установки на накопитель для следующих операционных систем:
    • Windows XP/2003;
    • Windows Vista/2008/7/8.
  2. Перенос PE среды на накопитель для следующих операционных систем:
    • Windows XP/2003;
    • Windows Vista/2008/7/8.
  3. Создать накопитель с загрузчиком Windows XP/2003.
  4. Создать накопитель с MS-DOS.
  5. Создать накопитель с консолью восстановления Windows XP/2003.
  6. Создать АнтиСМС/Винлокер загрузочный накопитель.

Выбрав Тип задания, нажмите на кнопку Создать для перехода к настройке параметров переноса.

Далее, в зависимости от выбранного типа задания вам необходимо будет определить параметры задания, число которых зависит соответственно от выбранного типа задания.

На рисунке ниже приведён пример окна настройки параметров для переноса программы установки Windows XP/2003.

Перенос программы установки Windows XP/2003

Окно настройки параметров переноса программы установки Windows XP/2003

Все параметры переноса объединены вкладкам в верхней части окна в соответствии с принадлежностью определённой группе параметров.

По завершении всех необходимых настроек нажмите на кнопку Запустить, чтобы начать процесс создания загрузочного накопителя.

Для продолжения вам необходимо принять условия лицензионного соглашения Microsoft, установив флажок Я принимаю условия лицензионного соглашения, и нажать на кнопку Продолжить.

Условия лицензионного соглашения

Окно Лизензионное соглашение

На следующем этапе необходимо подтвердить форматирование накопителя, нажав на кнопку Продолжить, при необходимости предварительно заполнив поле Результат (в зависимости от настроек программы). Вы можете активировать дополнительное поле Результат в процессе работы, установив флажок Включить CAPTCHA, после чего необходимо будет заполнить соответствующее поле для подтверждения форматирования.

Расширенный диалог Предупреждение о форматировании (Captcha)

Окно Предупреждение о форматировании

После чего начнётся процесс подготовки вашего загрузочного накопителя (см. рисунок ниже).

Предупреждение Во избежание повреждения диска и возможных неполадок не извлекайте накопитель и не прерывайте начавшуюся процедуру подготовки накопителя.

Дождитесь завершения процесса переноса, когда индикатор состояния достигнет значения 100%, а ниже вы увидите статус Завершено, вы можете нажать на кнопку OK или Выход (Закрыть) для закрытия окна и возвращения к главному окну программы.

Процесс подготовки накопителя

Окно Подготовка...


Параметры переноса

содержание раздела

Основные параметры

Параметры установки

Этапы подготовки

Форматирование

Опции FAT

Проверка диска

Исправления

Загрузчик


Основные параметры

На вкладке Основные параметры необходимо указать источник (путь к файлам, подлежащим переносу) и USB накопитель, на который будет осуществлён перенос. Для указания путей вы можете воспользоваться кнопкой Выбрать напротив соответствующего элемента окна, после чего в открывшемся окне укажите путь или введите пути самостоятельно в полях ввода.


Параметры установки

На вкладке Параметры установки вы можете задать параметры установки (ответы на вопросы, которые задает ОС Windows в процессе установки).

Параметры установки обеспечивают возможность автоматизировать процесс установки Windows, предварительно настроив файл ответов.

Примечание Подробнее о том, как настроить Параметры установки, смотрите в разделе Параметры установки.


Этапы подготовки

На вкладке Этапы подготовки вы можете настроить процесс создания загрузочного накопителя.

По умолчанию WinToFlash использует такую конфигурацию, при которой задействованы (включены) все этапы подготовки. Для изменения состава этапов снимите или повторно установите флажок в левой части окна настроек, напротив соответствующего заголовка этапа.

WinToFlash обеспечивает следующие этапы подготовки, состав которых меняется в зависимости от типа задания.

Общие этапы для переноса программ установки Windows всех поддерживаемых версий:

  • Форматировать накопитель – этап, на котором осуществляется форматирование накопителя в соответствии с заданными параметрами, если вы оставили параметры форматирования без изменений, форматирование будет произведено программой в соответствии с настройками по умолчанию.
  • Собрать информацию о дистрибутиве – на этом этапе будет создан точный список файлов и папок для переноса в соответствии с дистрибутивом Windows.
  • Собрать информацию о текстовом этапе установки – подготовить информацию только о текстовом этапе установки. В процессе происходит подготовка информация о начальном этапе установки Windows XP/2003.
  • Собрать информацию о графическом этапе установки – подготовить информацию только о графическом этапе установки. В процессе происходит подготовка информация о графическом этапе установки Windows XP/2003.
  • Создать структуру каталогов – создание структуры каталогов на накопителе (на основании информации о дистрибутиве).
  • Скопировать файлы – копирование файлов в директории, созданные на этапе создания структуры каталогов.
  • Проверить USB накопитель на ошибки – осуществляется проверка накопителя на наличие ошибок, во избежание проблем в процессе установки Windows.
  • Установить загрузчик – этап, на котором происходит формирование файла boot.ini и копирование файлов загрузчика (например, ntldr/grldr).
  • Задать букву диска для программы – обеспечивает задание накопителю буквы диска W:, что позволяет предотвратить опознавание программой установки накопителя как диска С: на текстовом этапе установки, что может привести к нарушениям в процессе установки. Если в процессе установки у ваз возникли проблемы с проверкой диска W:, вы можете отказаться от использования этой опции, сняв флажок напротив соответствующего заголовка этапа.
  • Создать файл ответов – этап, который позволяет автоматизировать процесс установки Windows XP/2003 за счёт предварительной настройки файла ответов.
Предупреждение Настоятельно не рекомендуется отключать опцию, поскольку это однозначно приведёт к сбою в процессе установки, после чего вам необходимо будет повторить процедуру переноса, предварительно включив опцию в расширенном режиме работы программы, или воспользоваться мастером переноса.
Примечание Подробнее о том, как настроить параметры установки для файла ответов смотрите в разделе Параметры установки.
  • Добавить файлы сопровождения процесса установки (SSA) – на этом этапе происходит автоматический запуск файла сопровождения процесса установки Windows XP/2003 на графическом этапе установки операционной системы.
Предупреждение Не рекомендуется отключать опцию во избежание последующих возможных проблем с установкой, а также при использовании операционной системы.
Примечание Подробнее о файле сопровождения процесса установки (SSA), а также об особенностях его использования смотрите в разделе SSA.


Форматирование

На вкладке Форматирование вы можете определить опции форматирования, основной из которых является Файловая система, а также при необходимости настроить Конфигурацию MBR.

По умолчанию WinToFlash использует файловую систему FAT32 CHS для разметки накопителя. Если вы создали загрузочный накопитель в режиме мастера, после чего возникли проблемы при загрузке, изменяя тип файловой системы, вы можете устранить эту неисправность.

Примечание Использование файловой системы FAT16 приведёт к сокращению объёма накопителя до 2 ГБ. После использования загрузочного накопителя необходимо будет повторно отформатировать его, выбрав предыдущую файловую систему (например, FAT32 или NTFS).
Примечание Подробнее о том, как настроить Конфигурацию MBR, смотрите в разделе Конфигурация MBR.


Опции FAT

Параметры данной вкладки позволяют произвести детальную настройку любых опций FAT для обеспечения лучшей совместимости накопителя с различными компьютерами.

Все параметры на вкладке Опции FAT объединены в группу Конфигурация FAT16/32 и по умолчанию определены программой. Однако, вы можете настроить каждый из представленных параметров, внеся соответствующие изменения.

Примечание Подробнее о том, как настроить Опции FAT, смотрите в разделе Конфигурация FAT16/32.


Проверка диска

На вкладке Проверка диска вы можете настроить опции проверки логической целостности файловой системы накопителя, а также действия по исправлению ошибок и восстановлению данных файловой системы.

По умолчанию WinToFlash использует такую конфигурацию, при которой все опции проверки накопителя отключены. Вы можете самостоятельно определить состав опций, для этого установите или снимите (в зависимости от положения) флажок в левой части окна напротив соответствующего названия опции.

В WinToFlash предусмотрены следующие опции для проверки накопителя:

  • Исправлять ошибки – опция обеспечивает запуск проверки диска на наличие ошибок и исправление ошибок в случае их обнаружения.
  • Расширенный вывод – опция обеспечивает вывод на экран имен и полных путей проверяемых файлов и каталогов.
  • Проверить поверхность диска – опция обеспечивает поиск поврежденных секторов и восстановление хранящихся в них данных. В случае, если вы используете эту опцию одновременно с опцией Проверять, если диск помечен как грязный, программа будет осуществлять проверку только при наличии у тома метки «грязный» бит.
  • Проверять, если диск помечен как грязный – опция обеспечивает поиск поврежденных секторов и восстановление хранящихся в них данных, только в том случае если программа определит, что для тома задана метка «грязный» бит. Метка «грязный» бит (dirty bit) может означать, что: файловая система находится в неустойчивом состоянии. «Грязный» бит может быть задан в случаях: если том находится в подключенном состоянии и в нем имеются незаконченные изменения, из-за того что компьютер был выключен до того, как сделанные изменения были переданы на диск, или в случае обнаруженных повреждений тома.
Примечание Использование опций проверки возможно только в случае использования платной версии программы (профессиональная или бизнес лицензии).


Исправления

Исправить ошибку STOP 0x6В SESSION3_INITIALIZATION_FAILED – опция позволяет избежать возникновения фатальной ошибки в процессе установки операционной системы Windows XP/2003, которая возникает при переносе альтернативных сборок дистрибутивов Windows или их фан-образов дисков.

Примечание Использование опции исправления возможно только в случае использования платной версии программы (профессиональная или бизнес лицензии).


Загрузчик

На вкладке Загрузчик вы можете определить способ загрузки операционной системы.

GRUB – загрузчик операционной системы, который обеспечивает лучшую совместимость с различными компьютерами (материнскими платами).

Примечание Использование опции выбора загрузчика возможно только в случае использования платной версии программы (профессиональная или бизнес лицензии). Для персональной, а также для бесплатной версий по умолчанию программа будет использовать стандартный загрузчик.


Обслуживание накопителя

Быстро очистить накопитель – это способ форматирования, который обеспечивает создание новой таблицы файлов без полной перезаписи или стирания информации USB накопителя. При записи в раздел новой информации происходит перезапись, то есть информация, хранящаяся на накопителе, уничтожается (стирается) вновь записываемой.

Преимущество быстрой очистки, заключается в том, что ее выполнение занимает значительно меньше времени, по сравнению с полной очисткой накопителя.

Недостаток такого способа заключается в том, что после выполнения форматирования данные на накопителя подлежат восстановлению. Что необходимо учитывать, в случае, если вы используете форматирование для того, чтобы полностью удалить с накопителя важную конфиденциальную информацию. Для этих целей необходимо использовать полную очистку.

Полностью очистить накопитель – это способ форматирования, который обеспечивает создание новой таблицы файлов и полное стирания информации USB накопителя. После выполнения форматирования данные на накопителя не подлежат восстановлению. Такое форматирование рекомендуется применять при наличии сбойных участков на накопителе и для его полной очистки.

Преимущества. Полная очистка позволяет высвободить дополнительное пространство для хранения информация за счет полного удаления всей информации с накопителя. Полная очистка при форматировании позволяет найти и исправить сбойные сектора, что в свою очередь также может увеличить свободное пространство на накопителе.

Недостаток полной очистки заключается в том, что его выполнении занимает значительно больше времени, по сравнению с быстрой очисткой накопителя.


Рабочие профили

Профиль – это файл конфигурации сделанных настроек и параметров форматирования в расширенном режиме работы программы, позволяющий, один раз настроив процесс переноса, многократно использовать в будущем заданные параметры.

Профили используются для сохранения параметров переноса в расширенном режиме и не влияют на настройки программы в целом.

В WinToFlash предусмотрено два режима работы с профилями: простой и расширенный диалоги.

Работа с профилями осуществляется с использованием следующих элементов управления, доступных из меню Задание:

  • Загрузить;
  • Сохранить;
  • Сохранить как.

По умолчанию WinToFlash используется простой диалог работы с профилями. Простой диалог предусматривает использование папки Profiles, расположенной в рабочей папке программы, для сохранения и загрузки профилей. В соответствии с этим WinToFlash выводит упрощённые окна: при сохранении профиля необходимо в поле ввода ввести название сохраняемого профиля или воспользоваться кнопкой Авто (для автоматического именования профиля) и нажать на кнопку Сохранить; при загрузке – выбрать из списка загружаемый профиль и нажать на кнопку Загрузить.

Расширенный диалог взаимодействия с профилями отличается тем, что при загрузке и сохранении профилей программой выводится диалоговое окно Windows.

Расширенный диалог предусматривает следующие варианты взаимодействия с профилями:

  • использование папки Мои документы,
  • использование произвольной папки по вашему выбору.
Примечание Подробнее о том, как осуществляется переключение между диалогами профилей, а также о дополнительных параметрах смотрите в разделе Профили.


Использование накопителя

Для того чтобы осуществить загрузку с подготовленного накопителя, необходимо изменить порядок загрузки устройств в BIOS компьютера или выбрать устройство в загрузочном меню.

Примечание На старых компьютерах (материнских платах) функция выбора устройства в загрузочном меню отсутствует. В этом случае необходимо будет менять порядок загрузки устройств в BIOS.
Примечание Для получения дополнительной информации о том, как войти в загрузочное меню или BIOS, а также как изменить порядок загрузки устройств обратитесь к инструкции вашего компьютера (материнской платы).

В случае успешной загрузки с накопителя вы увидите один из следующих загрузочных экранов, в зависимости от используемого загрузчика:

Загрузочный экран – стандартный

Загрузочный экран – GRUB

Для начала загрузки операционной системы выберите пункт 1st, text mode setup… и нажмите клавишу Enter.

По окончании первого этапа установки Windows компьютер будет перезагружен. Должна произойти повторная загрузка с накопителя, на появившемся загрузочном экране необходимо выбрать пункт 2nd, GUI mode setup, continue setup... и нажать клавишу Enter для продолжения установки.


АнтиСМС

WinToFlash содержит модуль АнтиСМС (АнтиВинлокер), то есть позволяет создавать загрузочный накопитель WinPE, содержащий модуль AнтиСМС. Модуль АнтиСМС обеспечивает автоматическое лечения вашего компьютера от программ-вымогателей, блокировщиков и троянов, которые блокируют ОС Windows, требуя от вас отправки СМС для разблокировки системы.

Создание

Загрузочный накопитель с АнтиСМС создаётся в расширенном режиме WinToFlash, для его создания выполните следующие действия:

  1. Выберите вкладку Расширенный режим в верхней части окна;
  2. В списке Задание выберите пункт Создать АнтиСМС/Винлокер загрузочный накопитель и нажмите на кнопку Создать;
  3. На вкладке Основные параметры необходимо указать расположение файлов WinPE и USB накопитель для подготовки;
  4. Нажмите на кнопку Запустить, чтобы начать процесс создания загрузочного накопителя.

Запуск

Для запуска АнтиСМС выполните следующие действия:

  1. Перезагрузите компьютер и укажите USB накопитель в качестве основного загрузочного устройства;
  2. После запуска WinPE откройте корневую папку USB накопителя и запустите файл AntiSMS.exe.
Предупреждение WinToFlash не запускает АнтиСМС автоматически.

Лечение

После запуска программы откроется окно (см. рисунок ниже), которое оповещает о том, что программа АнтиСМС выполняет лечение.

АнтиСМС (лечение системы)

Окно Начало работы

Программа AntiSMS автоматически выполняет все необходимые действия для лечения зараженной системы. По окончании процедуры лечения откроется соответствующее окно (см. рисунок ниже).

АнтиСМС (результат работы)

Окно Результат работы


Настройка приложения

содержание раздела

Окно Настройки приложения

Интерфейс

Журнал событий

Ядро

Профили

Статистика

Обновление

Форматирование

Результаты тестов


Окно Настройки приложения

Все настройки, определяющие поведение и управляющий работой программы, разнесены по категориям в соответствии с логикой программы.

Окно настройки состоит из двух частей:

  • в верхней части окна можно выбрать категорию, объединяющую один или несколько элементов управления, которую нужно настроить;
  • в нижней части окна содержатся элементы управления, с помощью которых можно настроить работу программы по выбранной в верхней части окна категории.

Переключение между категориями осуществляется выбором соответствующей вкладки, подлежащей настройке.

Окно Настройки приложения

Окно Настройки приложения

Вы можете открыть окно настройки одним из следующих способов:

  • перейдя по ссылке language… в нижней части главного окна программы;
  • выбрав пункт Настройки в меню Сервис главного меню программы.


Интерфейс

В категории Интерфейс сосредоточены следующие элементы управления по настройке внешнего вида программы:

  • Язык – выбор языка программы, выбор осуществляется из числа доступных языковых пакетов.
  • Стиль – настройка графического стиля интерфейса.
  • Использовать эффект прозрачности – управление опцией эффекта прозрачности, позволяет настроить степень прозрачности главного окна при открытии окон и выводе диалогов программы.
  • Запускать в режиме мастера – при запуске программы автоматически будет осуществляться переключение в режим мастера.
  • Спрашивать перед открытием веб-страниц – запрос программы перед открытием веб-страниц, для просмотра содержимого которых необходимо подключение к сети Интернет.
Примечание После внесения необходимых изменений в настройки программы нажмите на кнопку Применить или OK для того, чтобы внесённые вами изменения вступили в силу, нажатие кнопки OK сохранит изменения и закроет окно Настройки приложения.


Журнал событий

Журнал событий – функция журналирования работы программы, то есть ведение отчёта (сохранение информации) о ваших действиях и работе программы. Журнал – это лог-файл, в который заносятся сведения о работе WinToFlash, отчёт хранится в папке Logs, расположенной в рабочей папке программы.

Для настройки опции Журнал событий выполните одно из следующих действий:

  • чтобы отключить опцию, снимите флажок Использовать журнал событий, отключение опции делает неактивным элемент управления Уровень детализации журнала;
  • чтобы включить опцию, установите флажок Использовать журнал событий, включение опции активирует элемент управления Уровень детализации журнала.

    • Уровень детализации журнала:

  • Минимальный – в лог-файл заносится основная информация о проделываемых пользователем действиях и о ходе работы программы.
  • Средний – в лог-файл заносится основная информация о проделываемых пользователем действиях и о ходе работы программы, однако, в отличие от минимального уровня детализации, заносимая в лог-файл информация является более подробной и содержит дополнительные сведения.
  • Детальный – в лог-файл заносится информация о проделываемых пользователем действиях, о ходе работы программы, а также детальная информация по всему процессу переноса.
Предупреждение Не рекомендуется отключать опцию Использовать журнал событий, так как в этом случае WinToFash перестаёт собирать и записывать информацию о работе программы. Что в случае возникновения проблем в работе WinToFash затруднит рассмотрение вашего обращения службой технической поддержки в виду отсутствия отчёта о работе программы.
Примечание После внесения необходимых изменений в настройки программы нажмите на кнопку Применить или OK для того, чтобы внесённые вами изменения вступили в силу, нажатие кнопки OK сохранит изменения и закроет окно Настройки приложения.


Ядро

Разрешить использование сторонних утилит – эта опция позволяет использовать в ходе работы WinToFash вспомогательные сторонние утилиты.

Примечание Данная опция носит служебный характер и относится к числу упразднённых возможностей.


Профили

В категории Профили сосредоточены следующие элементы управления по настройке работы программы с профилями:

  • Использовать простой диалог работы профилей – снятие флажка и отключение опции, означает, что вы переключаете WinToFlash в расширенный диалог работы профилей.

    • Отключение опции делает активными следующие элементы управления:

    • папка Мои документы – устанавливает по умолчанию папку Мои документы для сохранения и загрузки профилей.
    • путь – позволяет самостоятельно выбрать папку для сохранения и загрузки профилей, которая будет использоваться по умолчанию.
Примечание После внесения необходимых изменений в настройки программы нажмите на кнопку Применить или OK для того, чтобы внесённые вами изменения вступили в силу, нажатие кнопки OK сохранит изменения и закроет окно Настройки приложения.


Статистика

Включить статистику – опция управляет функцией сбора программой статистической информации (число запусков, полное время работы, время и дата последнего запуска).

Примечание После внесения необходимых изменений в настройки программы нажмите на кнопку Применить или OK для того, чтобы внесённые вами изменения вступили в силу, нажатие кнопки OK сохранит изменения и закроет окно Настройки приложения.
Примечание Для просмотра статистики выберете пункт Статистика в меню Справка главного меню программы.


Обновление

Включать автоматическое напоминание об обновлении – управление режимом автоматического оповещения и соответствующих напоминаний о наличии доступных обновлений.

Примечание После внесения необходимых изменений в настройки программы нажмите на кнопку Применить или OK для того, чтобы внесённые вами изменения вступили в силу, нажатие кнопки OK сохранит изменения и закроет окно Настройки приложения.


Форматирование

В категории Форматирование сосредоточены следующие элементы управления по настройке уведомлений о форматировании:

  • Уровень подтверждения форматирования – опция используется для уведомления о предстоящем форматировании перед началом процесса переноса. Определяет поведение программы в соответствии с выбранным уровнем подтверждения. По умолчанию для уведомления о форматировании, программой используется уровень подтверждения Умный, однако при необходимости можно настроить уровень подтверждения самостоятельно.

    • Для настройки опции Уровень подтверждения форматирования выполните одно из следующих действий.

    • Чтобы отключить подтверждение форматирования, переместите ползунок в положение Не спрашивать и нажмите кнопку ОК. Уведомление о форматировании будет отключено.
    • Чтобы включить подтверждение форматирования, переместите ползунок в положение, соответствующее требуемому уровню подтверждения, и нажмите кнопку ОК. Уведомление о форматировании будет включено в соответствии с выбранным уровнем подтверждения.

      • В программе предусмотрены следующие уровни подтверждения:

    • Каждый раз – каждый раз при запуске процесса переноса WinToFlash будет запрашивать подтверждение начала форматирования.
    • Умная – программа определяет наличие пользовательских данных на накопителе, в случае, если накопитель пуст, подтверждение форматирования не требуется, если же WinToFlash определит наличие каких-либо файлов или каталогов – запрашивается подтверждение.
    • Не спрашивать – отключение запроса о форматировании накопителя.
  • Включить САРТСНА – опция дополнительного подтверждения форматирования накопителя, при включении данной опции программа запросит ответ на заданное математическое действия. Т.е. для подтверждения форматирования вам необходимо будет решить математический пример, после чего ввести ответ в соответствующее поле.
Примечание После внесения необходимых изменений в настройки программы нажмите на кнопку Применить или OK для того, чтобы внесённые вами изменения вступили в силу, нажатие кнопки OK сохранит изменения и закроет окно Настройки приложения.


Результаты тестов

Я соглашаюсь пересылать статистику – установив флажок, вы разрешаете программе в автоматическом режиме передавать на сервер Novicorp статистическую информацию.

Примечание После внесения необходимых изменений в настройки программы нажмите на кнопку Применить или OK для того, чтобы внесённые вами изменения вступили в силу, нажатие кнопки OK сохранит изменения и закроет окно Настройки приложения.
Примечание Подробнее о том, какие данные пересылает программа, смотрите в разделе О собираемых данных.


Расширенная настройка переноса

Расширенная настройка позволяет определить (назначить) Параметры установки, настроив файл ответов, параметры форматирования: Конфигурация MBR в категории Форматирование и Конфигурация FAT16/32 в категории Опции FAT.

содержание раздела

Параметры установки

Конфигурация FAT16/32

Конфигурация MBR


Параметры установки

Параметры установки обеспечивают возможность автоматизировать процесс установки Windows, предварительно настроив файл ответов.

Для настройки данных параметров необходимо предварительно выбрать пункт Пользовательский в списке Уровень настройки программы установки.

Параметры установки содержат и обеспечивает настройку следующих параметров:

  • Лицензионное соглашение Microsoft Windows принято – установив флажок, вы сможете пропустить этап установки, на котором необходимо принять условия лицензионного соглашения конечного пользователя.
  • Автоматически разбить на разделы – в процессе установки автоматически будет произведена разметка жёсткого диска на разделы.
  • Языковая группа – задаёт поддержку языковой группы операционной системой, установленной на компьютере. Указывается в формате: «1,2,3,4,5» (без кавычек), где цифры 1-5, указанные через запятую, определяют пять языковых групп (Western Europe and United States, Central Europe, Baltic, Greek и Cyrillic).
  • Язык – задаёт язык по умолчанию установленной системы. Определяется в формате 4-символьного кода (для России – 0419).
  • Имя пользователя – поле задаёт имя пользователя Windows. Введите используемое по умолчанию имя пользователя. Если оставить это поле пустыми, имя и организация не будет указано в файле ответов, эту информацию будет предложено ввести во время установки Windows.
  • Компания – поле задаёт название организации. Введите используемое по умолчанию название организации. Если оставить это поле пустыми, название организация не будет указано в файле ответов, эту информацию будет предложено ввести во время установки Windows.
  • Серийный номер Windows – поле служит для ввода ключа продукта. Введите в соответствующие поле 25-символьный код продукта устанавливаемой копии Windows XP (маска ввода: XXXXX-XXXXX-XXXXX-XXXXX-XXXXX).
  • Имя компьютера – поле служит для ввода имени компьютера (максимум 15 символов).
Предупреждение Имена компьютеров не могут содержать пробелов и следующих символов: " / \ [ ] : | < > + = ; , ? *.
  • Временная зона – поле служит для задания временной зоны (часового пояса). Каждая зона определяется последовательностью 3-х цифр (например, значение 145 определяет временную зону – (UTC+03:00) Волгоград, Москва, Санкт-Петербург).
  • Автоматически конфигурировать сетевые адаптеры – установив флажок, вы соглашаетесь на автоматическую настройку сетевых компонентов в процессе установки Windows. Установка TCP/IP, включение DHCP, установка клиента для сетей Microsoft для каждого конечного компьютера. Установите этот флажок, если не планируется выполнять настройки сетевых компонентов вручную.
  • Рабочая группа – поле позволяет задать имя рабочей группы, в составе которой конечные компьютеры будут участвовать в работе сети (например, WORKGROUP).
  • Путь установки – поле позволяет указать папку (путь), в которую следует установить Windows на конечном компьютере.
Предупреждение Папка установки должна иметь стандартный путь формата 8.3 для DOS, то есть не более 8 символов в названии папки, исключая пробел и следующие недопустимые символы: " / \ [ ] : | < > + = ; , ? *.


Конфигурация MBR

Параметры этой группы обеспечивают настройку главной загрузочной записи (MBR). MBR – совокупность кода и данных, необходимая для последующей загрузки операционной системы, расположенная в первых физических секторах на накопителе или другом устройстве хранения информации.

Для настройки параметров этой группы предварительно снимите флажок Выбрать параметры автоматически на вкладке Форматирование.

Группа параметров Конфигурация MBR содержит и обеспечивает настройку следующих параметров.

Признак активности раздела

Признак активности раздела – признак, обозначающий возможность загрузки операционной системы с данного раздела. Для стандартных загрузчиков может принимать следующие значения:

  • 0x80 – раздел является активным,
  • 0x00 – раздел является неактивным.

Тип раздела

Два вида логической адресации LBA и CHS. WinToFlash позволяет использовать два вида логической адресации при форматировании, это обеспечивает максимальную совместимость для использования загрузочного накопителя на различных компьютерах.

Примечание CHS не позволяет выполнять адресацию более чем к 7,8 ГБ данных, и для адресации к разделам, находящимся за пределами 7,8 ГБ, используется LBA-адресация.

Расширенный раздел – это первичный раздел, который не содержит собственной файловой системы, а содержит другие логические разделы. Используется для жёстких дисков, обеспечивает такую конфигурацию, при которой таблица разделов MBR может содержать более 4-х первичных разделов.

Координаты CHS

Поля ввода CHS начала и CHS конца – это координаты начала и конца раздела соответственно в CHS-формате (цилиндр, головка, сектор).

Допустимые значения: номер головки определяется числом в диапазоне от 0 до 255, число секторов – от 1 до 63.

LBA адресация

LBA первого сектора – номер первого сектора в LBA-формате.

LBA размер – размер раздела (количество секторов) в LBA-формате.


Конфигурация FAT16/32

Для настройки параметров этой группы предварительно снимите флажок Выбрать параметры автоматически на вкладке Опции FAT.

Вы можете настроить следующие параметры:

  • OEM имя – текстовая строка с аббревиатурой фирмы-изготовителя и номером версии операционной системы (по умолчанию используется ключевое слово «NOVICORP»). OEM имя необходимо задавать символами верхнего регистра, то есть прописными (заглавными) буквами.
  • Байт на сектор – число байтов в секторе (всегда 512).
  • Секторов на кластер – число секторов в кластере. Поле может содержать значения, равные 2N: 1, 2, 4, 8, 16, 32, 64.
  • Резервных секторов – число резервных секторов в резервной области раздела, начиная с первого сектора раздела. Для FAT16 данное поле всегда имеет значение 1, а для FAT32 – обычно значение 32.
  • Копий FAT – число таблиц (копий) FAT в разделе (число копий может изменяться в диапазоне от 1 до X, классически – 2, для экономии места можно указать 1, для отказоустойчивости – 3, 4).
  • Записей корневой папки – для FAT16 – количество 32-байтных дескрипторов файлов в корневом каталоге (при использовании FAT16 равно 512); для FAT32 это поле имеет значение 0.
  • Тип носителя – тип носителя информации.
Примечание Подробнее о допустимых значениях для параметра Тип носителя смотрите в разделе расширенная настройка Конфигурация MBR.
  • Секторов на FAT – для FAT16 – количество секторов, занимаемых одной копией FAT, для FAT32 поле имеет значение 0.
  • Секторов на трэк – число секторов на дорожке.
  • Головок – число головок.
  • Скрытых секторов – число скрытых секторов, предшествующих разделу, содержащему данный том. Значение равно 0 для носителей, не подлежащих разбиению на разделы.
  • Всего секторов – общее число секторов в разделе (используется, если размер раздела превышает 65 535 секторов, в противном случае поле содержит значение 0).


Обновление программы

Регулярное обновление WinToFlash позволяет избежать возникновения ошибок в работе программы, делает её работу более стабильной и производительной, предоставляет возможность использования новых функций.

Предупреждение Перед выполнением обновления программы необходимо сохранить все данные и выполнить полное резервное копирование копирование папки программы.

содержание раздела

Мастер обновления

Автоматическое оповещение об обновлениях

Ручная проверка обновлений

Проверка обновлений на сайте программы


Мастер обновления

Мастер обновления обеспечивает актуальность используемой версии программы.

Мастер обновления при запуске проверит доступность новой версии WinToFlash, после чего выдаст результаты проверки в виде соответствующего сообщения. Если по каким-либо причинам мастеру не удалось выполнить проверку, возможно, в процессе работы мастера у вас возникли проблемы с Интернет-соединением. В этом случае вы можете повторить попытку проверки ещё раз, нажав кнопку Повторить, или воспользоваться мастером позднее.

Результатом работы мастера будет информация о наличии доступных обновлений или об актуальности используемой версии WinToFlash в случае их отсутствия.


Автоматическое оповещение об обновлениях

Программа по умолчанию оповестит вас при появлении новой версии об имеющихся обновлениях.

Примечание Условием для работы автоматического оповещения является включенная опция автоматическое напоминание об обновлении, а также наличие активного Интернет-подключения.

В автоматическом режиме предусмотрены следующие типы оповещений о наличие доступных обновлений.

  1. Окно оповещений, выводится при закрытии программы, диалог которого предполагает выбор одного из следующих действий:
    • Да, запустить мастер и потом выйти – запуск Мастера обновления, по окончании работы которого при нажатии кнопки Выход (или Закрыть) произойдёт завершение работы программы.
    • Да, запустить мастер и не выходить – запуск Мастера обновления, по окончании работы которого при нажатии кнопки Выход (или Закрыть) произойдёт завершение работы самого мастера, после чего можно будет продолжить работу с программой.
    • Нет, просто выйти – отказ от обновления и завершение работы программы.

    Окно оповещений о доступных обновлениях

  2. Уведомление (ссылка) в нижней левой части главного окна программы, нажатие на которую, при наличии доступных обновлений, вызывает Мастер обновления.

Автоматическое оповещение об обновлениях, а также соответствующие напоминания можно отключить одним из следующих способов:

  • в окне Настройки, перейдя в категорию Обновление снимите флажок Включить автоматическое напоминание об обновлении;
  • снимите флажок Включить функциональность обновлений в Окне оповещений о доступных обновлениях.

После отключения опции программа не будет автоматически вас информировать о доступных обновлениях, однако, проверку обновлений можно будет выполнить в любой момент самостоятельно, используя функцию ручной проверки.


Ручная проверка обновлений

Ручная проверка обновлений отличается тем, что действия по проверке производятся вами самостоятельно, с использованием Мастера обновления.

Функция ручной проверки обновлений необходима, когда вы отказались от автоматического оповещения, внеся соответствующие изменения в настройки программы.

Примечание Условием для работы функции ручной проверки обновления является наличие на вашем компьютере активного Интернет-подключения.

Для проверки обновления в ручном режиме вы можете воспользоваться Мастером обновления, выбрав пункт Проверить наличие обновлений, в меню меню Справка главного меню программы.


Проверка обновлений на сайте программы

Вы можете узнать о новых версиях программы самостоятельно в любое время на сайте www.wintoflash.com.


Лицензирование программы

содержание раздела

Лицензия

Типы лицензий

Активация

О собираемых данных


Лицензия

Лицензионное соглашение содержится в файле EULA RuRu.RTF, расположенном в папке Documents в рабочей папке программы.

Лицензионное соглашение – это юридическое соглашение между вами и Novicorp, в котором указано, на каких условиях вы можете использовать программу.

Предупреждение Внимательно ознакомьтесь с условиями Лицензионного соглашения перед началом работы с программой.

Вы можете ознакомиться с условиями Лицензионного соглашения при первом запуске программы WinToFlash.

Считается, что вы принимаете условия Лицензионного соглашения, установив флажок Я принимаю лицензию и нажимая кнопку Далее > при запросе Мастера первого запуска, подтверждая этими действиями своё согласие с текстом Лицензионного соглашения при первом запуске программы.

Если вы не согласны с условиями Лицензионного соглашения, вы должны завершить работу программы нажатием кнопки Выход (или Закрыть) в окне Мастер первого запуска.


Типы лицензий

Это программное обеспечение бесплатно для некоммерческого (домашнего или в образовательных учреждениях) использования с базовой функциональностью. Если вам требуются дополнительные функции для профессионалов, вы можете купить Профессиональную лицензию. Для использования в бизнесе необходимо преобрести Бизнес лицензию.

WinToFlash поставляется на условиях «Как есть». Никаких гарантий не представляется и не подразумевается. Вы используете программное обеспечение на свой собственный риск. Novicorp не отвечает за возможную потерю данных, повреждение, убытки или другие потери, связанные с использованием этого программного обеспечения.

Типы лицензии

Для WinToFlash доступны 4 типа лицензии:

  1. Бесплатная лицензия даёт право домашнего использования программы. Каждая копия WinToFlash, загруженная с сайта www.wintoflash.com, уже имеет встроенную Бесплатную лицензию. Она включает базовые функциональные возможности и отображает рекламу в интерфейсе программы.
  2. Персональная лицензия даёт право домашнего использования программы. При покупке Персональной лицензии вы получите свой собственный файл лицензии, зарегистрированный на ваше имя, WinToFlash будет отображать ваше имя в диалоговом окне О программе, также в интерфейсе программы больше не будет выводиться реклама.
  3. Профессиональная лицензия даёт право домашнего использования программы и предоставляет доступ ко всем функциональным возможностям для профессиональных пользователей (администраторов, разработчиков и других IT-специалистов). Этот тип лицензии предусматривает работу с программой только для домашнего использования.

    4. Вы получите свой собственный файл лицензии, зарегистрированный на ваше имя, WinToFlash будет отображать ваше имя в диалоговом окне О программе.

  4. Бизнес лицензия отличается тем, что даёт право использовать программу для коммерческого применения, также, как и Профессиональная лицензия, предоставляет доступ ко всем функциональным возможностям для профессиональных пользователей (администраторов, разработчиков и других IT-специалистов).

    5. Вы получите свой собственный файл лицензии, зарегистрированный на ваше имя, WinToFlash будет отображать ваше имя в диалоговом окне О программе.

Примечание С полным списком всех возможностей различных типов лицензий WinToFlash, а также с информацией по их приобретению вы можете ознакомиться на официальном сайте WinToFlash в разделе Лицензия.


Активация

Активация – это процедура введения в действие лицензии, дающей право на использование полнофункциональной версии программы в течение срока действия лицензии.

Вам предлагаются следующие варианты активации WinToFlash:

– активировать коммерческую версию. Выберите этот вариант, нажав на кнопку Активировать лицензию в окне Мастер первого запуска и укажите файл лицензии, если вы приобрели коммерческую версию программы.

– активировать бесплатную версию. Выберите этот вариант активации, нажав на кнопку Далее > в окне Мастер первого запуска, если вы хотите использовать бесплатную версию программы для ознакомления перед принятием решения о покупке коммерческой версии, а также в случае, если вы не предполагаете использование функций, доступных в коммерческой версии. Бесплатная версия программы имеет ограничения функциональных возможностей, срок использование бесплатной версии неограничен.

Мастер первого запуска

Oкно Мастер первого запуска

После того как вы указали файл ключа, мастер проверит файл и выведет в окне соответствующую информацию о лицензии: тип, имя владельца, а также дату окончания срока действия лицензии.

После этого вы можете нажать на кнопку Далее > для установки ключа или при необходимости выбрать другой файл ключа.

После установки ключа мастер информирует вас об успешном завершении активации, нажав кнопку Далее > (или Закрыть), вы сможете покинуть Мастер первого запуска и начать работу с приложением.

Способы активации

Для активации коммерческой версии вы можете воспользоваться одним из следующих способов:

  • нажать на кнопку Активировать лицензию в окне Мастер первого запуска и активировать лицензию в соответствии с приведённой выше инструкцией;
  • предварительно удалить файл лицензии бесплатной версии в папке License и поместить туда полученный по e-mail файл лицензии.
Примечание Удостоверится в том, что программа зарегистрирована должным образом, с использованием персонального файла лицензии, вы можете, открыв диалоговое окно О программе, доступное из меню Справка.


О собираемых данных

Для повышения уровня осведомлённости специалистов Novicorp об использовании программы, а также для её дальнейшего улучшения и совершенствования WinToFlash собирает и отправляет на сервер Novicorp следующую статистическую информацию: VID, PID накопителя, результаты тестирования скорости, размер и имя производителя. Передаваемая информация не содержит персональных данных и иной конфиденциальной информации.

Сбор и отправка служебной информации не являются обязательными условиями использования программы и осуществляются исключительно с вашего согласия.


SSA

Что такое SSA

SSA (Setup Support Application) – компонент WinToFlash, файл сопровождения процесса установки Windows XP/2003, который используется на графическом этапе установки и выполняет ряд следующих функций:

  • обеспечивает повторное использование накопителя,
  • устанавливает правильный файл boot.ini,
  • устраняет ошибку, возникающую при установке пакета Microsoft Office 2007.

Использование

Для использования компонента SSA программа WinToFlash предусматривает модификацию файла txtsetup.sif.

Если в процессе установки ОС вы получили сообщение об ошибке вида:
Цитата inf-файл txtsetup.sif испорчен или отсутствует, состояние 18
вы можете отказаться от использования файла сопровождения процесса установки. Однако, это потребует ручного запуска компонента SSA по окончанию процесса установки во избежание последующих проблем или самостоятельной конфигурации файла boot.ini для обеспечения корректной загрузки операционной системы.

Если вы отказались от использования файла сопровождения процесса установки, внеся соответствующие изменения, при настройке процесса переноса в расширенном режиме работы программы, вы можете запустить его самостоятельно с помощью командной строки.

Синтаксис командной строки:

ssa.exe /команда

Обращение к компоненту SSA осуществляется через командную строку из каталога WinToFlash, по следующему пути: «…\ValueAdd\Novicorp\SSA» (где «…» – название рабочей папки программы), либо с указанием полного пути к ssa.exe.

Перечень команд, используемых для управления компонентом SSA, приведен в таблице ниже.

/Help или /? | Показать справку и игнорировать все остальные параметры.
/RenameFolders | Поиск и переименование .∼BT и .∼LS папок установки в .BT и .LS.
/UnrenameFolders | Поиск и переименование .BT и .LS папок установки в .∼BT и .∼LS.
/BootINIGenerate | Генерировать файл boot.ini при первом входе в систему.
/PendingDelete | Удаление компонентом SSA самого себя после следующей перезагрузки.
/Office2007ProblemFix | Исправить проблема с установкой пакета Microsoft Office 2007.
/DoNotAutoClose | Не закрыть приложение до полного завершения его работы.
/Verbose | Подробный вывод.

Обращаясь к компоненту SSA, вы можете указывать одновременно несколько команд.

Синтаксис командной строки для нескольких команд:

ssa.exe /команда1 /команда2 /командаN


История версий

Первый релиз WinToFlash состоялся 4 июля 2009 года. С этого момента и до настоящего времени программа активно развивается и совершенствуется. В ходе развития программы добавлялись новые функции и возможности, оптимизировался процесс быстродействия, как самой программы, так и компонентов, входящих в состав WinToFlash. Улучшалась стабильность работы программы, устранялись уязвимости, расширялась языковая поддержка.

С полным списком истории версий WinToFlash, а также перечнем их изменений вы можете ознакомиться на официальном форуме WinToFlash на странице История изменений. На сайте программы, в разделе Загрузка, вы также можете при необходимости скачать любую из опубликованных ранее версий программы.


Обратная связь

Если в данном руководстве вы не нашли интересующую вас информацию, у вас есть предложения по усовершенствованию программы, вы обнаружили ошибки в работе программы или вы хотите поделиться своим мнением об использовании программы, с этим вы можете обратиться к разработчикам используя форму обратной связи.

Для обращения в службу поддержки воспользуйтесь формой обратной связи, доступной из меню Справка.

Для того чтобы отправить обращение необходимо заполнить следующие поля:

  1. Номер клиента Novicorp – номер файла лицензии, используемой вами копии.
  2. Ваше имя – имя или другая предпочитаемая форма обращения.
  3. E-mail – адрес электронной почты для обратной связи.
  4. Заголовок – тема сообщения, вы можете выбрать тему сообщения из числа доступных, также предусмотрена возможность указать свою тему, выбрав пункт Свой заголовок.
  5. Свой заголовок – своя темя сообщения, в случае если вы выбрали Свой заголовок как тему обращения.
  6. Отзыв – текст сообщения, если ваше обращение связано с возникновением той или иной проблемы в работе программы, то необходимо подробно изложить возникшую проблему, а также действие, которые привели к её возникновению.
Предупреждение Размер сообщения не должен превышать тысячи символов, текущий размер отображается в нижней части окна.

После того, как вы заполнили все поля, нажмите кнопку Отправить.

Примечание Отправка сообщения в службу поддержки осуществляется при условии наличия активного Интернет-подключения.

Установив флажок Отложить и закрыть окно при отправке, если нет связи с Интернет, вы можете отложить отправку сообщения с сохранением заполненных полей до момента появления активного Интернет-подключения.

Кнопка Отложить позволяет отложить отправку сообщения в случае отсутствия Интернет-подключения на момент написания сообщения. В дальнейшем, при условии наличия активного Интернет-подключения вы можете повторить отправку сообщения, повторно обратившись к форме обратной связи.

Для закрытия окна нажмите кнопку Отмена (или Закрыть), при этом содержание заполненных вами полей будет утеряно.

Веб-сайт "Novicorp WinToFlash": | www.wintoflash.com/home/ru/
Служба поддержки: | support@novicorp.com
Cпециальный форум по лицензированию: | www.wintoflash.com/forum/viewforum.php?f=14 (только в случаях, если файл лицензии не получен или был потерян)
Веб-форум "Novicorp WinToFlash": | www.wintoflash.com/forum/viewforum.php?f=6